ArlissWallace

Spartan Chassis Front End Ongoing Squeak

Recommended Posts

We have a 2008 Newmar Kountry Star diesel pusher that we have had for about 3 years.

From the beginning of our ownership, we noticed an excessive annoying squeak in the front end - especially while on wavy or uneven up and down roads - (probably passenger side) that we have tried to have repaired.

They have lubed the front end (not sure exactly which areas) and it has helped for a bit. We have had the ride height checked, replaced the shocks, and had the generator checked to see if it was not secure. And still we have the noise.

We have talked to both Newmar and Spartan to ask for help in resolving our issue (we do believe there is something wrong as we have owned many motor homes and recognize this as a problem). The only thing we know left to check are the control arm bushings or the tie rods.

Any other ideas? Has anyone else had this experience with the Spartan chassis?

We would appreciate your help and advice. 

Share this post


Link to post
Share on other sites
FIVE   

We had a very similar noise coming from under the passenger's seat in an 09 AC Allegiance, with a Spartan chassis, we bought new.  

After numerous checks by numerous facilities, it was discovered there were a number of factory welds missing on that side.  

Also, the dealer (now out of business), had the coach checked before we bought it, discovered the problem, but neglected to tell us about it.

Share this post


Link to post
Share on other sites
manholt   

ArlissW.  Welcome to the Forum!

Since you have an independent front suspension, I would suspect the tie rod on Co Pilot side.  I have the K2 chassis !  Sounds on a DP is hard to track down, I had a squeak and rattle on the Co Pilot side, we thought it was coming from the front wheel area.  Turned out to be, from the slide that was 1/4" off center, when inn position, right behind front seat. :rolleyes: Slide out was adjusted, no more sound.

Share this post


Link to post
Share on other sites

Thanks for your replies...we will be taking the motor home back for service after the first of the year. We now know to have them look at the control arm bushings and possibly loose control arm bolts, tie rods, loose alignment eccentrics (whatever that is). We have a name of someone we can have our service center call at Spartan so we are hopeful that we will resolve this problem soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now