Jump to content


Icon Welcome to the FMCA Motorhome Forums!

Register now to gain access to all of our features. Once registered and signed in, you will be able to create topics; post replies to existing topics; upload pictures; manage your profile; get your own private messenger; create blogs; and more. Sign up now! Already have an account? Sign in. This message will be removed once you are signed in.


Photo
- - - - -

Electric Water Heater Trobleshooting

Electric Water Heater

  • Please log in to reply
2 replies to this topic

#1 Spearfish

Spearfish

    Newbie

  • Members
  • Pip
  • 2 posts
  • Location:Pennsylvania
  • I travel:With Pets

Posted 30 October 2012 - 09:01 PM

We have a 2004 Four Winds Infinity and just found on our last trip that our electric water heater was not heating the water so we used gas to heat the water.
Could the problem be a fuse or a heating element? All other electric sysytems appear to be in good working order.
  • 0

#2 desertdeals69

desertdeals69

    Advanced Member

  • Members
  • PipPipPip
  • 1,156 posts

Posted 30 October 2012 - 11:00 PM

Could be the thermostat on the tank. See if you have 120v to the heat element.
  • 0

#3 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,373 posts

Posted 31 October 2012 - 02:31 PM

Spearfish,

The thermostat can be an issue, but make sure that there is power to the 110 volt connection for the power feed to the temperature control board or relay. Could have come unplugged or just a loose connection in the circuit.

The power feed on my hot shot gets bumped at times and no power to the heating control circuit board for the AC element.

Rich.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users