daddude

Hot Water Heater Not Working

7 posts in this topic

I used hotwater heater for first time in over a year recently on used motorhome and nothing.

The previous owner said it had worked. I cleaned and checked parts per manual still no go.

Propane has to travel long distance from front.Am I not waiting long enough?

Propane reaches and operates the fridge when needed though.Any advice would be greatly appreciated.

Share this post


Link to post
Share on other sites

Is you heater gas and/or electric and if so does it heat on AC?

Share this post


Link to post
Share on other sites

The manual says the first thing to do is unplug and replug the connector on the control board several times.

If its an Atwood you can download a trouble shooting manual HERE

Share this post


Link to post
Share on other sites

Should your hot water heater be located in the rear of the coach, and has not been used for an extended period of time it might take some time before the gas reaches the burner.

Do you get a spark at the water heater burner ? Do you hear the gas valve open(click when first turned on) ?

If you get both the click and a spark, you may need to cycle it a number of times before the LP reaches the water heater valve.

Rich.

Share this post


Link to post
Share on other sites

Thanks for download site for atwood heaters. Will read and perform tests next month when I dewinterize RV for upcoming trip. Hope I find the problem. THANKS AGAIN AND SAFE RVING!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now