Jump to content


Photo
- - - - -

Weldex Backup Camera


  • Please log in to reply
8 replies to this topic

#1 cadiwa

cadiwa

    Newbie

  • Members
  • Pip
  • 8 posts
  • Location:Prince Albert Sk. Canada

Posted 17 May 2013 - 11:45 PM

Does anyone know where to get help to diagnose a Weldex backup camera that is not working?

 

Picture flickers and then goes off after 1/2 hr. or so.

 

Where would I be able to get a replacement that fits in the existing dash opening?


  • 0

Wayne Cadieu, 2007 CC Inspire 360, C9 Caterpillar


#2 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,604 posts
  • Location:Where ever the wheels stop ?

Posted 18 May 2013 - 12:51 AM

cadiwa,Welcome to FMCA.

Could you post the model number of your camera in question.

I'm a little confused in regards to your post. You mention the camera and then ask about a unit that would fit into your current monitor location in the dash. Are you thinking of replacing the system, camera and dash display unit or just looking for information on the camera repair?

You can go to this sight and get some information on MRA (Material Return Authorization)

 

http://cms.weldex.co...dex.php/support

 

or you can try to contact them


Weldex Corporation
2500 Packard St, #101B
Ann Arbor, MI 48104
US

Telephone: 734-272-4690

Email: return@weldex.com

 

Hope this helps Rich.


  • 0

#3 wolfe10

wolfe10

    Advanced Member

  • Moderator, Super
  • PipPipPip
  • 3,771 posts
  • Location:League City, Texas

Posted 18 May 2013 - 05:39 AM

Another excellent source for diagnostic information as well as direct replacements is http://www.rvcams.com/Default.htm

 

The have several full time repair techs in-house.


  • 0

Dianne and Brett Wolfe
2003 Alpine 38'
Moderator, FMCA.com Forums
Chairman, FMCA Technical Advisory Committee
Member, FMCA Long-Range and Development Committee 2007-2009
Moderator, http://www.dieselrvclub.org/(FMCA chapter)


#4 mrboyer

mrboyer

    Advanced Member

  • Members
  • PipPipPip
  • 351 posts
  • Location:Anderson, Indiana

Posted 19 May 2013 - 02:22 PM

I second RVCams.  Having replace 3 Weldex monitors, they are notorious for heat failures.  There is not a direct replacement from another manufacturer, but you can run a new cable from the camera to a new monitor that is another brand.  RVCams will help you decided.  The newer digital Weldex color displays are supposed to be better than the older model displays.


  • 0

Ross & Melanie Boyer

2006 Fleetwood Expedition 37U

Cat C-7 300HP

Allison MH3000

 

 

 


#5 trophy987

trophy987

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 August 2013 - 08:48 AM

I had the same problem.  Service tech at Thibodeaux's Supreme RV Service in Lafayette, Louisiana solved the problem.  He bent the pins in the connector just a little and the system has not failed again.


  • 0

#6 Larry196

Larry196

    Advanced Member

  • Members
  • PipPipPip
  • 101 posts
  • Location:Tulalip,WA
  • I travel:Full-time in my motorhome

Posted 26 August 2013 - 04:40 PM

I need an installation diagram for my Weldex.

 

Any one (other than Weldex) that may have a diagram about where the wires go ?

 

The installation is straight forward but it leaves me with the three wires that activate the side cameras, the wires are marked but no info where to connect them.

 

Larry


  • 0
Do something every day that scares you - even if just a little bit.
Larry and Rita F428262

#7 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,604 posts
  • Location:Where ever the wheels stop ?

Posted 26 August 2013 - 10:06 PM

Hi Larry,

 

Look at this link. Look at pages 10 to 12 for wiring. Hope it is what you have, so the information below is relevant.

If not list the model number and I will try to find some more info.

 

They made finding this information a little challenging. LOL

 

http://automotive.we...Manual_VER9.pdf

 

Rich.

 

The three wires are to switch the cameras when you back up, or turn. You will need something like a time delay relay circuit connected to the ignition run circuit,with the proper fuse to supply voltage to the control circuit that switches your new monitor between side cameras.

The back up signal can be supplied from the back up light circuit and and the manual switch on the monitor to keep the monitor connected to the rear view camera if you wish. Not that familiar with the circuits they use, to know if when you have a manual button selected the other ports can over ride the manual selection. If not and you want to be able to view the rear view camera an additional relay my need to be added to the turn signal control circuit.

 

I have one source on file that I can send you information on In a PM. I do not want to act as an add agency for them, but the product will do what you need, if your coach did not come with a 3 camera system.

 

The other key piece of information is the required control voltage to switch the monitor logic between inputs for the cameras, They(the cameras) will be on whenever the monitor is power up.


  • 0

#8 teddychamp

teddychamp

    Newbie

  • Members
  • Pip
  • 8 posts
  • Location:Duncan, SC

Posted 02 September 2013 - 05:25 PM

 I had the same problem with mine. Installed Color backup system with the same results and just to find out that black and white has better picture. Replaced cable from camera to monitor and fixed the problem.


  • 0

#9 Mikeulappa

Mikeulappa

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 30 November 2013 - 11:44 AM

Had a different problem.  Camera view stuck in right view mode while in the automatic mode.  Would change to the rear view when left turn signal turned on, then revert to right view when turn signal returned to null position.  The manual mode worked fine.  Problem seems to have cleared after sitting for two days.   Any idea what caused this?


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users