Jump to content


Icon Welcome to the FMCA Motorhome Forums!

Register now to gain access to all of our features. Once registered and signed in, you will be able to create topics; post replies to existing topics; upload pictures; manage your profile; get your own private messenger; create blogs; and more. Sign up now! Already have an account? Sign in. This message will be removed once you are signed in.


Photo
- - - - -

Workhorse Instrument Cluster Failure


  • Please log in to reply
6 replies to this topic

#1 parkridge

parkridge

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 20 October 2013 - 04:34 PM

2006 Pace Arrow on a Workhorse chassis.  I can no longer read the  mileage and other info on the display.  Any suggestions?  Someone suggested the Scan Guage II but not sure that will show mileage.


  • 0

#2 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,372 posts

Posted 21 October 2013 - 12:11 AM

Parkridge, Welcome to FMCA !

 

I sent you a PM with some information. I hope it answers your question.

 

Rich.


  • 0

#3 zorro2kita

zorro2kita

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Location:Somewhere in the USA
  • I travel:Full-time in my motorhome

Posted 21 October 2013 - 10:20 PM

Please share the info as mine is slowly fading to a point that it may not be readable next year --


  • 0
2003 Pace Arrow - 37A Workhorse Chassis 8.1L Vortec engine - Toad - 2009 Saturn Vue - Pilot - Nick Co-Pilot - Sandy

#4 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,372 posts

Posted 21 October 2013 - 11:25 PM

zorro2kita,

 

When you mention fading, are you referring to the intensity of the display or the light level of the cluster while driving at night?

Trying to understand if its a LED display intensity level or the back lighting when you are driving at night.

 

Be aware that tampering with the cluster can cause it to lock up and it will need to be replaced !!!

 

Rich.


  • 0

#5 zorro2kita

zorro2kita

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Location:Somewhere in the USA
  • I travel:Full-time in my motorhome

Posted 22 October 2013 - 10:27 AM

Rich   -   LCD display intensity level  is the culprit  -  I do not drive the coach at night and I've cranked up the dial for the highest back lighting -  any further advice ??

 

NIck


  • 0
2003 Pace Arrow - 37A Workhorse Chassis 8.1L Vortec engine - Toad - 2009 Saturn Vue - Pilot - Nick Co-Pilot - Sandy

#6 DickandLois

DickandLois

    Advanced Member

  • Members
  • PipPipPip
  • 1,372 posts

Posted 22 October 2013 - 10:32 AM

Nick, Did you manage to fine the link I sent to your email box using the PM-Private Messenger?

 

It explains how to use the mode button to access the set up tree.

 

Rich.


  • 0

#7 zorro2kita

zorro2kita

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • Location:Somewhere in the USA
  • I travel:Full-time in my motorhome

Posted 22 October 2013 - 09:32 PM

Rich  -  did not see the link but may have deleted this from my spam folder -  could you please send again ?  Thanks -  NIck


  • 0
2003 Pace Arrow - 37A Workhorse Chassis 8.1L Vortec engine - Toad - 2009 Saturn Vue - Pilot - Nick Co-Pilot - Sandy




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users