Sign in to follow this  
Followers 0
txtode

Water Pump---No Power

5 posts in this topic

Water pump--No power
Out of the blue my water pump lost power or ground. The salesman switch is by-passed. The on-off switches do not light up. Fuse in panel in bedroom is good. Fuse in line to pump is good. Is there another fuse? Getting power thru fuse in bedroom but no farther. Very confused.

Don
__________________
1999 Monaco Dynasty 40'PBS

Share this post


Link to post
Share on other sites
Hello Don,


I'm guessing a bad ground at the latching controller or the controller has failed. The latching controller is activated by a temporary ground at any of the switches, the relay turns on those lights and provides ground to the pump.


You should have battery voltage at the pump, likely you didn't see it. If it has no power, the controller will still turn the indicator lights on.


Warren

Share this post


Link to post
Share on other sites

Open the basement, particularly left side just in front of rear wheels. Have someone turn it on and open a faucet. That would be my first suspect.

Share this post


Link to post
Share on other sites

I would tilt the fuse panel and see if it lost the connection going out from it since you have no power at the switch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0