Jump to content


Photo
- - - - -

Water Pump---No Power


  • Please log in to reply
4 replies to this topic

#1 txtode

txtode

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 November 2013 - 08:51 PM

Water pump--No power
Out of the blue my water pump lost power or ground. The salesman switch is by-passed. The on-off switches do not light up. Fuse in panel in bedroom is good. Fuse in line to pump is good. Is there another fuse? Getting power thru fuse in bedroom but no farther. Very confused.

Don
__________________
1999 Monaco Dynasty 40'PBS

  • 0

#2 wajames

wajames

    Member

  • Members
  • PipPip
  • 24 posts
  • Location:Southwestern US
  • I travel:Full-time in my motorhome

Posted 11 November 2013 - 10:14 PM

Hello Don,
 
I'm guessing a bad ground at the latching controller or the controller has failed.    The latching controller is activated by a temporary ground at any of the switches, the relay turns on those lights and provides ground to the pump.
 
You should have battery voltage at the pump, likely you didn't see it. If it has no power, the controller will still turn the indicator lights on.
 
Warren

  • 0

#3 frankbibber

frankbibber

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 January 2014 - 10:19 AM

 I have a 92 Safari Serengetti and cannot locate this water pump.

 

Where is the water pump located?


  • 0

#4 wolfe10

wolfe10

    Advanced Member

  • Moderator, Super
  • PipPipPip
  • 3,757 posts
  • Location:League City, Texas

Posted 19 January 2014 - 01:24 PM

Open the basement, particularly left side just in front of rear wheels.  Have someone turn it on and open a faucet.  That would be my first suspect.


  • 0

Dianne and Brett Wolfe
1997 Safari Sahara 3540
Moderator, FMCA.com Forums
Chairman, FMCA Technical Advisory Committee
Member, FMCA Long-Range and Development Committee 2007-2009
Moderator, http://www.dieselrvclub.org/(FMCA chapter)


#5 huffypuff

huffypuff

    Advanced Member

  • Members
  • PipPipPip
  • 407 posts
  • Location:Camano Island, Washington
  • I travel:With Pets

Posted 20 January 2014 - 12:38 AM

I would tilt the fuse panel and see if it lost the connection going out from it since you have no power at the switch.  


  • 0
At Redmond, OR

 

 

Ray & Hana Huffman

2006 Holiday Rambler, Ambassador PLQ 40' 10" 

2006 Jeep Liberty Limited CRD used as toad

2012 Cadillac SRX4

1976 Cadillac Coupe deVille

2009 7,000 lbs Carhauler Trailer





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users