Jump to content

Timnjulie

Members
  • Content Count

    30
  • Joined

  • Last visited

Everything posted by Timnjulie

  1. Yeah, there's only 1 switch. When I first looked at the rv in a storage bldg. he turned on the switch by the door and all the lights storage areas lit up.
  2. I spoke with previous owner and he said there's only 1 switch which is by the entry door. The entry switch lights up but none of the storage compartment lights come on. Still looking.
  3. I will look for another light switch. There's one at the entry and when I turn it on, no lights.
  4. Recently I was going to replace a few burned out light bulbs in the 38' Damon Astoria storage basement area. I turned on the lights but nothing happened in any of the compartments. Obviously I figured it was a breaker or fuse. With my limited experience (new 1st time motorhome owner) I looked at all the fuses and double checked the breakers and did not find any problems,. What am I missing or doing wrong? Thanks!
  5. I ended up up venting thru the air bleed on top of the 'stat housing. and added more coolant. No more alarms! 😀 Test drive on freeway and temperature remains on the cooler side of normal at75 mph and on grades. So new Cummins thermostat, clean CAC, clean radiator, no more high temperatures. Thanks everyone from rookie RVers! Quote
  6. I replaced the thermostat with Cummins part, cleaned CAC and radiator good. Started engine and immediately got stop engine light and alarm, did I trap air? I vented radiator thru upper petcock until I got coolant for a few seconds and had heater running. Noticed temperature guage did not move either.
  7. I'll remember to wash it before I put it back😁
  8. I plan to do the cleaning and change thermostat this weekend and see how it does. Is the thermostat on a 2005 300 HP Cummins diesel difficult to replace?
  9. Put toothbrush in my coach toolbag
  10. Cleaned thermocouple tip with toothbrush, fired right up using a match, thanks for the "tip".
  11. Turns out I was low on coolant. I put in 1/3rd of gallon, rv center said all they did was add 1 pint of coolant and now it works fine. Seems odd I was just 1 pint old, but hey it works fine now.
  12. tried lighting oven in motorhome, pilot won't light, worked fine 5 weeks ago.
  13. I have called the generac 800 number on the generator and couldn't find anyone to talk with.
  14. I have it scheduled to be looked at by Cummins sales and service center. Hopefully they can resolve it without too much expense.
  15. The meter has 825 hrs. The coolant was a little low. Topped it off but it still shuts down almost after 6 minutes every time.
  16. That's an expensive way to resolve the problem but glad to hear it's working good for you. Thanks alot for your feedback, I appreciate it. I plan to take it to the Freightliner dealership that works on semi diesel engines, I'll do what I can. Thanks again!
  17. I'm not sure how to access error codes. I will check the hours but they are low. I'll double check the coolant level but the generator was recently serviced. Thank you
  18. Thank you! I made sure fuel was at 1/2 tank, so it wasn't a low fuel condition.
×
×
  • Create New...