Jump to content

Recommended Posts

I'll start with a little history. Bought 2016 Tiffin Phaeton 3 months ago. Coach was 11 months old with 7400 miles.

We are having an issue with the fresh water foaming initially when we open the faucets. This is NOT normal foaming from the aerator. The foam will almost stand up in your hand and has an odor to it. I have filled and flushed the fresh tank at least 15 times. I have used Spring Fresh in the tank.

The condition also exists when we are connected to any fresh water supply which leads me to believe the issue is within the water lines on the coach. I have also run water, both hot and cold thru faucets separately for as long as 15 minutes. 

The condition still persists. I was thinking that possibly the winterize fluid was left in and it left a residue behind that is causing the issue. 

I am worried about having any contact with this liquid.

Can anyone offer any possible solutions?

Share this post


Link to post
Share on other sites

Have you sanitized the system? If not I would try that. Mix bleach according to your manual and let is sit for 3-4 hours then completely flush. Your symptom are strange. We do get some foaming if the Mh has been sitting for awhile or when I hook up city water as air does get in the lines.

You could also have a small leak somewhere letting air in but I doubt it.

Have you changed out the in house filter?

Share this post


Link to post
Share on other sites

The foaming clears up after about 30 seconds and is OK until it sits like over night. Don't think it is air leak since it clears up. I'll try to sanitize it but I the the Spring Fresh was to take care of that.

Thanks for your input

Share this post


Link to post
Share on other sites

RV antifreeze in the fresh water tank can cause that. It really isn't harmful but I didn't like it when it happened to me with my first motor home. After that I added a bypass/pump system and did not put any antifreeze in the tank.

RV antifreeze is polyethylene glycol which is a food additive  - in small amounts -  and a laxative  -   Mirilax and others - in larger amounts.

I had to fill and flush the tank several times to eliminate it. 

Share this post


Link to post
Share on other sites

pvgsma, try the bleach/water mixture and flush the system. We place it in the fresh tank and drive the coach to agitate the mixture with 1/2-3/4 tank of water, then I will run the pump opening up different faucets throughout the coach to get rid of it and allow it to fill the gray tank at least one time, then pull the gray tank valve (I figured it would help clean that too on the way out). Once the fresh tank is empty I fill it with straight water and run it empty via the pump back through the coach, this usually purges a large portion of the bleach smell.

Our first coach sat for three years with old RV antifreeze in it prior to our purchase, no foam but it stunk horribly.

here is a video

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...