Mikerodg

No Water From Kitchen Sink

Recommended Posts

Mikerodg   

I have an 03 Phaeton Class A. All of a sudden my new kitchen sink faucet has zero water coming out. Not even a drip.

Yesterday afternoon it was working fine. Checked the water lines underneath loose and one connection water came out so I know I have water going to the faucet connection lines. Toilet and all other things are working just fine.

Any thoughts please.

Share this post


Link to post
Share on other sites

Is it a single handle type faucet that mixes hot and cold water?  If taking the strainer off and cleaning it doesn't work, like Bill suggests above, your mixer valve may be bad.  Home Depot sells replacement valve cartridges for Moen, American Standard etc.  You can take your faucet off - a little bit of work - and bring it to the store to find the right cartridge.

Blake

Share this post


Link to post
Share on other sites
manholt   

I read..."my new kitchen faucet"! 

There may be another strainer where the water line connects to the faucet.  Turn water valve off for kitchen, should be under sink, get a bucket and disconnect water line or lines to faucet.  Place lines in bucket and turn on valve.

Carl

Share this post


Link to post
Share on other sites
jleamont   

Just turn the water supply off first before servicing the cartridge or replacing, believe me it happens to the best of us :wacko:

Share this post


Link to post
Share on other sites

As Blake stated.  We installed a new kitchen faucet in the S&B (they all work the same way) and when the plumber turned on the water the hot water side did not work.  He pulled out the "mixer" valve and there was a piece of debris blocking the hot water side. 

Who did the install.  Oops!

Share this post


Link to post
Share on other sites
Mikerodg   

Thanks guys I can always rely on you for answers. We're traveling from Denver down to Rocky Point Mexico. I have a stop in Las Cruces tonight and Tucson tomorrow. I'll try to find a Home Depot and buy a cartridge period and work on it when I get to Mexico. I'll give you an update when I've solved it

Share this post


Link to post
Share on other sites
manholt   

Mike.  You staying at the beach RV park?  Forgot the name, big and has a bar and restaurant at the entrance, Rhand side!  Cold beer, good food ! :)  You do know it's Spring Break.

Carl

Share this post


Link to post
Share on other sites

We had the same issue in our 2009 MH.  After cleaning everything, replacing the mixing valve, still nothing worked.  We had good pressure from the pipes before the faucet, but it would not get through the mixing valve area.  We replaced the entire unit.  No issues since, but I think my filter is going to be replaced on the next trip out.  Good luck..

Share this post


Link to post
Share on other sites
On 3/20/2017 at 1:30 PM, Mikerodg said:

Thanks guys I can always rely on you for answers. We're traveling from Denver down to Rocky Point Mexico. I have a stop in Las Cruces tonight and Tucson tomorrow. I'll try to find a Home Depot and buy a cartridge period and work on it when I get to Mexico. I'll give you an update when I've solved it

I don't know what faucet you have but I replaced my sink faucet with onr the head pulls out and can be used as a sprayer out to fill a tall pan. We like it a lot more than the stock one.

Bill

Share this post


Link to post
Share on other sites
Mikerodg   

Thanks Bill and Carl. Sorry I didn't get back to you sooner. I had to figure out how to set my devices on roaming down here and Rocky Point. Yes we're right on the beach at Playa Bonita RV Park. we got lucky facing the ocean watching the sun sets. We're going to have the rig painted down here full body paint for $4,500. The faucet was a simple fix as many things are. I detach the feed supply to the handle took apart the O-ring retaining a small spring plunger I think they were slightly out of whack put them back together blue through it and got a great stream of air hooked it up been working ever since.

Share this post


Link to post
Share on other sites
manholt   

Price of paint must have tripled...A member of the Escapees in AZ. had it done in 2015 for $2,800, full body on a 42 foot Fifth Wheel.  That's = to a 45 foot DP !

I was there and the result was a stunning transformation!!!

Carl

Share this post


Link to post
Share on other sites
wolfe10   

A lot of the cost of a paint job is the prep-- which can vary from a quick wash to a deep sanding.  Kind of hard to compare without a lot more facts.

Share this post


Link to post
Share on other sites
manholt   

Brett, your right.  It took a day and 1/2 to prep the trailer, 2 days for paint in 2 colors and 2 days for clear coating, 2 coats with sanding between each.

Carl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now