Jump to content
Sign in to follow this  
DaddoRV

Lippert autoleveling jacks

Recommended Posts

I have a Lippert auto leveling system that works fine except when you retract the jacks the fluid returns to the reservoir with such force that hydraulic fluid leaks from the reservoir cap.  I tightened the cap but still leaks.  

Any suggestions.  

Thanks Jack

 

 

 

Share this post


Link to post
Share on other sites

Start by checking the fluid level - when the coach is level with the jacks retracted. Over full? Maybe some air in the system - bubbles can cause the fluid ti spit.

Rich.

My bad ! By the way welcome to the FMCA Forum! Just got parked at home after returning from the warm South. Way to cold up North yet !!!  LOL

Share this post


Link to post
Share on other sites

Check the reservoir with he jacks retracted. If the hydraulic tank has a fill line make sure the fluid is at that line. If it is above, use a turkey baster and suck some out - nasty job as it wants to go everywhere. If it is below the line then fill it to the full mark.

If here is no line check your manual but most will have the line about 1 inch below the top of the tank.

Share this post


Link to post
Share on other sites

Welcome to the forum. If you add your coach and other information to your signature it will help to get good answers. So what do you have? Make Model Year?

The fluid should not be all that forceful returning to the reservoir as it is the springs pushing the fluid out of the jacks.

Do like others have said get it level and check the fluid level. I would look and see if it has a gasket on the fill plug?I don't remember if my plug has one or not right now. Also look for damage to the sealing surface that may cause a leak.

I run my fluid at where it just runs out with the plug out. 

Bill

Share this post


Link to post
Share on other sites

Thanks guys for your replies; I am a new guy to FMCA and appreciate your help.  I did get in touch with Lippert and they were nice, appearently the resivor cap is a vented cap and he told me to check that, which i did and is ok as far as i can tell. My plan now is to lower just a little the fluid level and replace the o ring gasket and see what happens. Sorry for not mentioning that I have a 2017 Sportscoach 404 RB. JACK

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...