Jump to content
pcowen

Shore Power 2014 Fleetwood Bounder

Recommended Posts

I keep my rig plugged in while in storage.  Noticed my energy management system was reading no power.  Started by confirming power was getting to rig from outlet.  Checked disconnects and no problem. Started my generator and energy management system picked up this power source.  Typically when on shore power after plugging in hear a relay switch click in surge protector and energy management system displays power source and ampage. While trouble shooting did not hear click sound today in surge protector.  Wanted to reach out to see if there are any other issues I should check before scheduling service apt.  Responses greatly appreciated. 
Phil Cowen

Share this post


Link to post
Share on other sites
34 minutes ago, pcowen said:

I keep my rig plugged in while in storage.  Noticed my energy management system was reading no power.  Started by confirming power was getting to rig from outlet.

What power source are you plugged into 30 or 50 amp? Have you checked  to see if you have 120 V power in the coach? 

 

38 minutes ago, pcowen said:

 Checked disconnects and no problem.

Are you talking about the circuit breakers?

Bill

Share this post


Link to post
Share on other sites

Phil,

As Bill asked, what power do you have your coach plugged into? 15, 30 or 50 amp? Also can you bypass your surge protector? It may be your issue.

Also, please let us know what coach you have. Knowing that can get a lot more information. If you put your coach information in your signature we would already know.

Good luck,

Herman 

Share this post


Link to post
Share on other sites

Mine does that once in a while. Every time, the Xantrex inverter remote panel reads "lost neutral". I go unplug the 20A extension cord, re-plug, go back, clear the inverter fault and power is restored. FWIW we are on REMC and do not have reliable service, the house lights blink once in a while, haven't confirmed any connection to the coach losing neutral  fault though.

This week I plan to replace both ends of the extension cord, which is a 75ft, 10/3; fed from our house main panel. If I'm out there working inside the coach I start the genset if I need air conditioning, LP furnaces if heat is needed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...