Jump to content
cmcusn

Shift pad power

Recommended Posts

Have a 2017 Discovery LXE 40X, problems with the Arens 5 gen SBW (shift by wire) pad.  Have ing power to pin 12 but no battery power to pin 13.  What I need is the location of the Vehicle Identification mod and picture showing the fuse and relays.

Thanks William

Share this post


Link to post
Share on other sites

cmcusn,

Welcome to the FMCA Forum.

What chassis are you on? That is where the wiring for the Allison would have been done. Normally, the two 12 VDC positives to the Allison ECU come from the same fuse block-- one for memory the other hot only when the ignition is on.

Verify that your ignition switch and ignition solenoid are working-- if the dash HVAC fan works, these are good.

Share this post


Link to post
Share on other sites

thanks for the response, the original problem was the dash air not working, read that it could be the relay, changed that and fixed it, but then wont start, just says "trans comm fail", all fuses that I can find are good.

fleetwood xcm chassis

 

replaced the relays and the dash air works, and the hacks retracted the first time i tried to start it

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...