Jump to content
patwhite

Power gear jacks will not work

Recommended Posts

I have a 2003 Fleetwood Providence with power gear manual hydraulic leveling system.  After a recent trip the power would come on but jacks would not extend (coach running, air system bled down, full fluid level, power panel 10A fuse good, 10A fuse on pump harness good).  I took it to RV repair, they said it worked fine,  I tried before I left and front jacks went down, but would not retract.  New control panel, same issue, no change.  What am I missing.  Currently when I turn on power to panel it shows jacks down, but all are retracted.  If I turn off parking brake, and put in gear it sounds alarm and flashes.  
 

I appreciate any help.

 

pat

Photos of jack pump assembly and contol pane are below.

 

916CD6FD-ACAB-4962-A1DF-4E78777EE1A5.jpeg

978ABEA0-647B-4261-8A67-208BCBF98E18.jpeg

Share this post


Link to post
Share on other sites

maybe stupid question,but how are your house batteries, charged and turned on?  also, have you checked wiring harnesses in the system for loose or frayed wires, or bad ground?

Share this post


Link to post
Share on other sites

Batteries are good.  Need ac power from ground power or generator to run the pump.  I have checked the harness visually, but don’t have the skill to do a continuity check.

 

Pat

Share this post


Link to post
Share on other sites
1 hour ago, patwhite said:

Problem solved!  Corroded connection on battery wire to pump.  10 cent part replaced, system works agsin.

53FF15DF-74DE-4009-9C37-5D31DDC3FFAF.jpeg

nice!  glad it was a simple fix!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...