Jump to content
smarksel

One-time Anitfreeze Leak in Sub-freezing Weather

Recommended Posts

I have a 2001 Safari with the Hydro-hot system.  While in sub-freezing weather in Williams, Az two months ago, I had a pool of anit-freeze under the RV, about 1/5 way back from the front, under the propane tank, adjacent to the Hydro-hot system.  I cannot get it to leak since.  I've even had it in the RV shop where they ran the Hydo-hot system for hours, also, no leak!  I then thought it might be from the dash heater, so I ran that for about 45 minutes, again, no leakage.  Any ideas why it may have leaked under 30 degree weather one time and not since.  The pool of anti-freeze was about 18" in diameter when it leaked.  

Steve 

Share this post


Link to post
Share on other sites

Mark,

The next time you have to run the Aqua Hot check the over flow reservoir. It has a low and a high mark. Check it now to see if it is above the low mark when cool. If it is above the mark the system may have been releasing the extra coolant as it expanded with the heat. :o

Too full is what it sound to me. Did it heat the coach well?  It is a great unit when operating correctly.

Herman 

Share this post


Link to post
Share on other sites

Thanks Herman

The level in the over flow reservoir is just below the low mark when cold and between the two marks when hot.  Functionally, it works very well.  I cannot get it to leak again.  

Steve 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...