Jump to content
Sign in to follow this  
LloydW

C9 Cat Won't Shut Off

Recommended Posts

The last two days of travel the engine will not shut off after approx. four hours of travel, this is with the the ignition switch off and the key removed. The solution has been to shut off the battery isolator switch. The system seems to work fine after that until the next few hours of operation.This is in a 2005 beaver. Suggestions please.

Lloyd

Share this post


Link to post
Share on other sites

Good news is it's electrical not mechanical. Somehow the shutoff solenoid is being fed electrical power when you shut off the ignition. You can verified this with a test light and unplugging the solenoid when engine is running. If engine shuts off at that point then try unplugging the ignition switch while engine is running. If engine shuts off when you disconnect the ignition switch, you found the problem. if not you need to take it to a chassis shop.

Share this post


Link to post
Share on other sites

Thanks Ray, I have just talked with my dealership and was advised that it was a backfeed from the daylite running lites [a Canadian requirement]. The solution is to have the headlite switch on and on low beam when you shut down. Seems to work.

lloyd

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...