Jump to content
Sign in to follow this  
jbikesv

Electric Jacks Retraction

Recommended Posts

I  was told electric jacks didn't like the cold. Sure enough it was about 20 degrees today and it took about 4 false starts before they went up.

Press the button, they would go up about a second and stop. Reset and then same thing.

After 4 tries the jacks went up, except the passenger side which only went up about 4 inches. I cycled them all down and then they all went up without a problem.

So..... Do I have a problem or is this somewhat normal?

Share this post


Link to post
Share on other sites

Weather is crap right now and the coach is in storage...sadly, outside. I think The jacks are Atwoods but it will take a day or so to get to it to look at the manuals- New coach to me, just celebrating a 2 week birthday. It will get north of 20 degrees next week and I'll run the jack down and clean them off.... will send updates as things develop.

Share this post


Link to post
Share on other sites

I have Power Gear electric jacks. I've never had problems due to temperature now moisture is a different story. If they are electric, the only thing to clean are the magnets on the edge of each leg. This is for position sensing.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...