Jump to content

rogedie

Members
  • Content Count

    3
  • Joined

  • Last visited

Recent Profile Visitors

2426 profile views
  1. My friend's heater ignition won't light when he camps in high altitude, but works fine at home near sea level.
  2. I have no tail lights or clearance lights. I have checked the breaker (under passenger seat) and it is good. I have also looked in rear (underneath) for bad wiring or connectors and all looks good there. Can anyone possibly give me some advice? My email address is jlceh1943@gmail.com
  3. During our recent annual AZ winter visit, we stayed at View Point Resort in Mesa. Upon plugging in we noticed no power. After checking the pedestal, my husband discovered an open neutral which allowed 220 to flow into our coach. This had blown out some of our electronics. We immediately called the office and their head maintenance person was sent over. He confirmed that there was bad wiring and told us to call a repair service he recommended and that the park would pay for damages. A week later when everything was fixed through major efforts on the part of the repair service, we submitted our bill. They took our information and we left. Several weeks later we received notification from their insurance carrier stating they felt they were not liable, because they didn't know about the bad wiring. We appealed this decision and were again denied coverage. The bill came to over $3,600.00. Our insurance ended up paying except for our $500 deductible, which now puts a mark against us. This is a very upscale park, but when it comes to standing behind their sites, BEWARE!!! This too could cost you.
×
×
  • Create New...