Jump to content
f442485

Power Gear Hydraulic Jack

Recommended Posts

Hi. I have a jack question to ask. My wife and I own a 2004 Holiday Rambler Endeavor with Power Gear hydraulic jacks.

I'm not sure how to word this, but the jacks will not lift the coach to level it. It is a manual system. As soon as the jacks touch down (touch the ground) they stop moving. I can still hear the pump working, but no lift. I've checked the fluid level and its full.

I tried to call Power Gear, but got no help.

Any suggestions?

I'm Rick Ammerman and live in Southern California, with my wife, Paula of 45 years.

Share this post


Link to post
Share on other sites

Sounds like the pump is not developing designed pressure.  I would  first check to determine that you have proper voltage to the pump to insure pump is reaching designed RPM's. You can isolate one cylinder at a time to see if the pump capacity is capable to extend one cylinder at a time.  You could have one cylinder that bypassing internally and preventing the system from reaching full pressure. Use caution when testing not to lift just one corner of the rig.

Jim

Share this post


Link to post
Share on other sites

Rich. 

When you say that your canister or reservoir is full...how full?  up to line or over line?  If over, you need to bleed off to line.  Also, do you have the Power Gear with override?  If you do, then go to manual and press on higher, it will lift all 4 corners at same time...but make sure first that your fluid is at proper level with all Jacks retracted !

If none of the above, then Google Power Gear and scroll down to the Hydraulic Jack parts list and problem solving...it's a PDF and you will need your 50-XXX-X number, then just scroll down to your system.

I found out last July, that if all else fails, call the 800# during lunch hour and you'll get a very nice lady, who knows nothing about how the system works, but if you tell her that your an installer for system # bla, bla, and you have to get the customer out ASAP...She will fax or download the whole PDF on your system...I have 63 pages on mine!  If you don't call when everyone is gone, you will get no useful info!

Carl

Share this post


Link to post
Share on other sites

I'm having the same problem with the Kwikee Level Best system on my 2008 Itasca. I understand that this is the same as :Power Gear.

I have an extended warranty but have been told that the problem is either deteriorated inside of hoses and/or blockage in the valve body,

neither of which would be covered under the warranty. The dealer, however said they would be happy to replace the hoses and rebuild the valve body

for only $5000.00. I'm looking for a more cost effective solution

Share this post


Link to post
Share on other sites

I haven't been told that. I'm looking for some tech. info so I can perform the repairs, while I'm still able.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...