Jump to content
hoskey

no suction at the water pump

Recommended Posts

I got the pump working fine a few weeks ago, but it cycles every minute or so.  There aren't any leaks.  Is there a setting on the pump to reduce cycling?

Share this post


Link to post
Share on other sites

hoskey,

Sounds to me like you have a bad check valve which is on the suction side of the pump. It isn't holding and after the pump reaches it's cut off pressure it slowly leaks down and will recycle as it gets to the low pressure.

A simple repair to remove the valve and replace it.

Happy travels.

Herman

Share this post


Link to post
Share on other sites

Could be a bad check valve.  Could also be that the valve you turn to add water is not sealing completely.  Either will allow/cause the pump to cycle, yet not leak water externally.

Open and close the fill valve a couple of times in case a piece of minerals is not allowing complete closure.

Share this post


Link to post
Share on other sites

Thanks.  I will follow up on your suggestions.  As I said with my electrical issue, after I get my income taxes done!!  I guess Uncle Sam comes first.  Neither problem is a serious issue.  We have water and electricity, just not like we want.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...