Jump to content
jasonkangas

Headlights, but nothing else

Recommended Posts

Got headlights but nothing else. 1993 E350 four winds.

Fuses are good. I've  read bad grounds to wheel tilt, to rodents to corroded connections on bulb to switch in steering column.

I understand the basics but not sure which one to troubleshoot first.

Seems to me if everything but the headlights might narrow the search, any suggestions?

Ps , I know t j.g e rodent might be an issue because my ratter dog was going nuts for a bit under the front of vehicle.  It could be my well meaning dog also grabbed a wire or two.

Share this post


Link to post
Share on other sites

Jason.  Welcome to the Forum!

You should have a "Salesman Switch" inside coach, close to door on Co-Pilot side, may or may not be marked.  Mine is the only toggle switch in coach!  In most coaches, it's easy to accidentally turn off, by you or a dog.  

Can you start the coach & Generator?

Share this post


Link to post
Share on other sites

Sales man switch? Wouldn't  that be an easy fix.

Yes I can start.

My signal relay was buzzing when I put left turn on. I replaced that. Did not fix problem

When headlights on the front blinkers are on but solid but work when flasher is on, but flashes to quick. 

Share this post


Link to post
Share on other sites

When you say you have headlights but nothing else, what exactly do you mean? You can start the engine, do your other chassis-related things works (the things you need the key on for, like dash heat, etc.)? Trying to understand if your problem is on the chassis side or the house side.

Share this post


Link to post
Share on other sites
On 12/14/2019 at 8:18 AM, jasonkangas said:

Got headlights but nothing else. 1993 E350 four winds.

Fuses are good. I've  read bad grounds to wheel tilt, to rodents to corroded connections on bulb to switch in steering column.

I understand the basics but not sure which one to troubleshoot first.

Seems to me if everything but the headlights might narrow the search, any suggestions?

Ps , I know t j.g e rodent might be an issue because my ratter dog was going nuts for a bit under the front of vehicle.  It could be my well meaning dog also grabbed a wire or two.

Need some clarification !

     You posted that the engine Starts. That makes one think your issue is the Turn signal circuit or maybe the 4 way flasher's not working. 

When the headlights are on do you have marker lights ?

Will just the marker / clearance lights when the switch is not all the way on in the headlight possession?

Do you have have 4 way flasher's?

There is a flasher unit like a (552 flasher) in the turn signal circuit and also in the 4 way signal circuit. What is buzzing the flasher unit(s) or a relay related to the circuit?

Rich.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...