Jump to content
kdrogers62

Back up camera not working

Recommended Posts

I have a 2007 Winnebago adventurer with a voyager camera system (original built in). There are two side cameras and one rear camera. The side cameras are still working fine but the rear camera has no picture and the message on the screen says no signal. Any suggestions? I’m assuming there must be some sort of connection problem.

Share this post


Link to post
Share on other sites

I worked on one of these systems before, similar concern, no side camera. Check the connections on the back of the monitor. 

Share this post


Link to post
Share on other sites

On ours, I could remove the camera and plug it directly into the back of the monitor to test. If it works, you know it is the cable or connectors. Maybe yours would too. If you do remove camera, tie a cord onto the cable before you disconnect. If the cable falls down between the end cap and RV wall, it is difficult to locate. I have had to replace 3 or 4 monitors and 3 cables in 20 years. 

Share this post


Link to post
Share on other sites

The camera cable on our Back Up camera looks like a telephone cable and had the same plug. Easy to replace. Tool sold in big box stores. Either plug may be bad.

Herman 

Share this post


Link to post
Share on other sites

Also check the ground connections, over 80% of all 12V issues are the result of a poor/missing ground.

Share this post


Link to post
Share on other sites

Kdrogers62, if your system is like ours, make sure you didn't accidentally switch the camera selection button, labeled "CA SEL", to the wrong position. 

I know in ours that if you do you get a "no signal" message across the screen, 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...