Sign in to follow this  
Followers 0
TonyP

Smartwheel

5 posts in this topic

I have a 2013 Holiday Rambler 43 ft Endeavour .I have trouble with my smartwheel controls shutting down and not coming on.

When this happens my cruise control and engine brakes and all controls on the smart wheel do not work. I had it in the garage to check it out but both times it worked and the problem was not diagnosed. Just as I take it on another run it shuts down again, It used to be intermittent but now its off & will not come on.

Can anyone help me here?

Would appreciate any assistance.

Share this post


Link to post
Share on other sites

Tony, I will get you the test information when I get home. The mfg. Is great with help.

Herman

Share this post


Link to post
Share on other sites

Tony,

Your Smart Wheel is made by "Vehicle Improvement Products, Inc." vipwheels.com or 847-395-7250.

When you go on their wed site look for a matching picture of your steering wheel. Click on to it and download the manual and copy. When you have done this call VIP and speak with a tech. Tell them your problem and they will tell you what page and paragraph to go and how to preform the correct test for your problem.

Good lick,

Herman

Share this post


Link to post
Share on other sites

Thanks Herman, that's good information, I have saved it. MY SW works okay with one little glitch...the accel/decel switches are wired backwards. As long as I remember that, I'm fine. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0